Let's look at various options that the PM Monitor menu makes available to us:


  1. Menu File



From file menu you can hide (Hide PM Monitor) PM Monitor in the system tray area (near the time).From thi situation,you can restore PM Monitor window with a double click. Also,when PM Monitor reduced to system tray,you can run some commands from menu that appears by right-clicking on the icon. The Exit item stops the service if it is still active and closes the application.


2.   Menu project



From project menu you can choose different options,Select Project allows you to select proman project to run on PM Monitor,while Select project folder allows to select folder that contain projects.Reload project recharges project selected. If communication service is able,this function stops it,then reload project and restart service. Start service entry starts communication service with other terminals by casting machines states. Stop Service stops the service,if errors occur when starting or stopping service,the text of this errors will report in page log. Log option allows you to manage text contained on log page of PM Monitor. Specifically, you can delete log or save it to a text file. Project statistics option displays some statistics on the project.Specifically:project tile,project loaded path,current company code,number of log tables,state machines,states and functions of PM Monitor.



3.   Menu Tools



Form tools menu,you can access at options (describe below) of the PM Monitor. Scheduled tasks allows,with a dedicate interface to schedule service start/ stop operations and connect/disconnect from PM Monitor database.Change company code allow you to modify company selected code at the first start of PM Monitor.



3.1 Le Opzioni




As described above,selecting Tools/options appears window to set PM Monitor options. Let's start by analyzing general page:


Autostart Service allows to active service communcation with terminals at the start of PM Monitor,loading the last project.


Initialize NetBox indicates whether to initialize netbox TMC at the start of service. This function must enable in the installation since it transfers to each Etherlite address of PC HOst that governs it and other configuration parameters.Once configured this value remains in the memory of Etherlite. .


Auto add Company Code allows to add company code before table name.NB: Company code is addes only in front of the table name of the select phrases set by PM select function.


Notify terminal connection with a message enables the feature that sends a message when a terminal connects.This option is useful when you want to send an initilization sequence to the termina when it is connected.


Mail Notification Settings you must set connection parameters for the mail server for sending emails from PM Monitor. E-mail may be sent to notify you of system malfunctions or the status of the machine in question. The SMTP server name/ address and TCP/IP port connection must set in detail.


Localization you can set date format from the NOW system charger and the date and time that affects all PM Monitor dates/times.  


Plant page allows you to set where you can find the system configuration.By selecting the Plant option,Pm Monitor loads system configuration and in the Models function the list of terminal models from xml files.



Remote Control page contains parameters for configuring remote control of PM Monitor web.In particular, you can enable/disable the service (enable option) and set up a username and password to connecting to the web and accessing the start/stop functions of communication service with remote terminals. Service port parameter indicates which TCP/IP port is listening to service. Notifications service allows you to receive notifications when service starting,stopping or when there are errors.




From Debug page, you can indicate the detail level of debugging information and check that log in memory does not get too big.In detail: Stardard debug option enables display of log information as in earlier versions of PM Monitor.Show Message option enables the log of messages received from each terminal,and show debug info item enables the log on the logs of the status jumps of each terminal to debug machine states.

By selecting Advanced debug, you can set a log level for each terminal through a special window.

Log size check section allows you to limit memory space occupied by log information.Specifically,you can enable log size control (enable option) and set the limit size that the log itself can reach.If the log reaches the specified size,you can indicate the operation to be perfomed by selecting to clear the log,delete the oldest lines log and save log into a file and then delete it from the memory.





Fault tollerance page contains configuration parameters for the PM Monitor redundancy function.

Pm Monitor redundancy means that at least two instances of it are lanched on the same network.An instance will work from "master",that is,from the main terminal operator.The other instance will play backup.Communication between the two instances occurs by TCP/IP connection,configured by the port parameters.Also,for the backup instance,you must specify the name or address on the computer that is running the master instance and the verification instance of the master instance presence by the backup instance. In the Options section,you can specify the detail level of the log that is on the log page,and if and where to send email notification of the system fault.





4.   Menu Help



Allows you to select activate the about window with information about PM Monitor version module or view the license information.




Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor